Multiple vulnerabilities in CouchDB

Posted: January 23, 2013 in Vulnerabilities
Tags: , , ,

Vulnerability

Vulnerabilities in CouchDB

Vulnerability: Multiple vulnerabilities in CouchDB

Danger: High
Patch: Yes
Number of vulnerabilities: 3

CVE ID: CVE-2012-5641
CVE-2012-5649
CVE-2012-5650

Vector of operation: Remote
Impact: Cross Site Scripting, Disclosure of sensitive data, System compromise

Affected products: Apache CouchDB 1.x

Affected versions: Apache CouchDB versions prior to 1.0.4., Apache CouchDB versions prior to 1.1.2., Apache CouchDB versions prior to 1.2.1.

Description:

The vulnerability allows a remote user to execute arbitrary code on the target system.

1. An error in the unescaped backslashes URL. A remote user can gain access to sensitive data on the system.

2. An error in the processing of the answer JSONP. A remote user can execute arbitrary code on the target system.

3. The vulnerability is caused due to insufficient input validation in certain parameters. This can be exploited to execute arbitrary HTML and script code in a user’s browser session in context of an affected site.

Manufacturer URL: http://couchdb.apache.org/

Solution: Install the latest version 1.0.4, 1.1.2 or 1.2.1 from the manufacturer.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s