The critical vulnerability in the web content management system Drupal

Posted: October 16, 2014 in Vulnerabilities
Tags: , , ,


Drupal vulnerabilitiesThe critical vulnerability in Drupal (CVE-2014-3704)

In the release of web content management system Drupal 7.32 fixed a critical vulnerability (CVE-2014-3704), which allows an attacker to send specially crafted requests resulting in arbitrary SQL execution. The vulnerability assigned the highest level of danger (Highly critical), what indicates the possibility of the remote attacks that can lead to gaining access to the system.

The vulnerability is caused by a bug in the implementation of the method “prepared statement” in thedatabase abstraction API and can be exploited by anonymous users. A vulnerability in this API allows an attacker to send specially crafted requests resulting in arbitrary SQL execution.

The vulnerability has been identified by Sektion Eins, a German PHP security firm that was hired to audit Drupal by an unnamed client.

All Drupal users are encouraged immediately upgrade their systems. The problem manifests itself including when you close the web site through translation into maintenance mode.

Drupal: Vulnerability Statistics

Vulnerabilities By Year

Vulnerabilities By Type

Unauthorized modification of data in Drupal

Danger level: Highly Critical
Availability Corrections: Yes
Number of vulnerabilities: 1
CVSSv2 Rating: (AV: N / AC: L / Au: N / C: P / I: P / A: P / E: U / RL: O / RC: C) = Base: 7.5 / Temporal: 5.5
CVE ID: CVE-2014-3704

Vector of operation: Remote
Impact: Unauthorized modification of data

Affected products: Drupal 7.x
Affected versions: Drupal versions prior to 7.32

Description:
The “Highly Critical” SQL injection allows an attacker to compromise the website.

[CVE-2014-3704] The vulnerability is due to the fact that the database abstraction API component does not properly handle user requests. This can be exploited to execute arbitrary SQL commands in the application database.

Note: Successful exploitation of the vulnerability allows a remote attackers to compromise a target system.

Example of a request to test their systems for vulnerability:

"?name[0%20;update+users+set+name%3d'owned'+,+pass+%3d+'$S$test'+where+uid+%3d+'1';
;#%20%20]=test3&name[0]=test&pass=shit2&test2=test&form_build_id=&form_id=user_login_block&op=Log+in"

Note: Information on the technique of attack has recreated some researchers and published in the network (CVE-2014-3704: Exploit 1, Exploit 2).

Solution: Install the latest version 7.32 from the manufacturer. If you did not patch Drupal or otherwise block the SQL injection attacks within hours of the announcement of Oct 15th, 4pm UTC, restore your website to a backup from before 15 October 2014.

Links:

https://www.drupal.org/SA-CORE-2014-005
https://www.drupal.org/PSA-2014-003


Drupal logoManufacturer URL:
https://www.drupal.org/

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s