Posts Tagged ‘Ruby on Rails’

Ruby on RailsDevelopers have eliminated dangerous vulnerability in Ruby on Rails, which allows the execution of arbitrary code on the system.

Developers of the popular framework has released a security update that fixes a critical vulnerability in the output JSON data. The vulnerability allows an attacker to execute arbitrary code via a specially crafted HTTP POST request containing the JSON code to insert YAML.

Vulnerabilities affect versions Ruby on Rails 3.0.19 or 2.3.15. Earlier versions may also be affected by this vulnerability.

Recall that a few weeks ago in the network has an exploit that uses a vulnerability in the XML handler for Ruby on Rails. So this is the second dangerous vulnerability in the framework, in January of this year. Last year, for the Ruby on Rails SecurityLab.ru released 5 security notifications, which have been described 10 vulnerabilities. None of the vulnerabilities in 2012, is not at a high risk rating. (more…)

Vulnerability

Execution of arbitrary code

Ruby on Rails JSON Processor YAML Deserialization Code Execution

Vulnerability: Execution of arbitrary code in Ruby on Rails

Danger: High
Patch: Yes
Number of vulnerabilities: 1

CVE ID: CVE-2013-0333
Vector of operation: Remote
Impact: System Compromise

Be exploited: PoC code
Affected Products: Ruby on Rails 2.3.x, Ruby on Rails 3.0.x

Affected versions: Ruby on Rails versions prior to 3.0.20 and 2.3.16.

Description:

The vulnerability allows a remote user to execute arbitrary code on the target system. (more…)

Vulnerability

Exploit for Ruby on Rails

In the web there are first reports of web-servers affected by hackers.

Since the disclosure of the critical gaps in the framework, Ruby on Rails web appeared not only exploits using this vulnerability, but the first reports of compromised with it web-servers. To date, the Metasploit module has appeared appropriate.

Note that this gap is extremely dangerous because it affects the very large number of applications and servers. Server administrators with Rails applications should update their software to the latest version. Recall that the updates that address just two holes, the developers have been published on Wednesday, January 9.

The vulnerability lies in the fact that the remote attacker can send data to the application as a POST request, and thus proekspluatirovat it. While Brescia affects all media in which the XML parser is active (default is active.) (more…)

Ruby on RailsVulnerability: System compromise in Ruby on Rails

Danger level: High
Availability of fixes: Yes
Number of vulnerabilities: 1

CVE ID: CVE-2013-0155
CVE-2013-0156
Vector of operation: Remote
Impact: System Compromise

Affected Products: Ruby on Rails 2.3.x, 3.0.x, 3.1.x, 3.2.x.

Affected versions: Ruby on Rails versions prior to 3.2.11, 3.1.10, 3.0.19, 2.3.15.

Description:

The vulnerability allows a remote user to execute arbitrary code on the target system.

An error in the processing of XML parameters, because of what the characters and YAML types can be part of a POST request. This can be exploited to compromise a vulnerable system. (more…)